tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу на паскале:
Написать программу на паскале: на вход целые числа до появления нуля. вывести максимальное количес тво подряд идущих чисел, кратных 3.
babohka1
1 27.08.2019 05:50
3
Ответы
Cherep666
31.08.2020 22:25
Var
x, n, max: integer;
begin
n := 0;
max := 0;
while true do
begin
read(x);
if(x mod 3 = 0)and(x<>0) then n := n + 1
else begin if(n > max) then max := n; n := 0; end;
if(x = 0) then break;
end;
write(max);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
SkyForce144
27.03.2020 09:12
2.5, 2.6, 2.7 решение в С++...
nastya788rf
06.06.2019 23:51
Составить программу движения прямоугольника снизу вверх...
Dimas1694
07.06.2019 02:50
Pascal написать процедуру для расчета степени n вещественного числа a ( n-натуральное число)....
Kornella
18.09.2019 06:30
Пользователь вводит трёхзначное число. программа определяет, входят ли в него цифры 0 и 5 одновременно....
nellit03
18.09.2019 06:30
Есть ли у екранов планшетов ограничение по нажатиям? (типо как у мышки, например, 10000000 кликов, и она уже не работает)...
vikaMiwka
24.04.2020 20:27
Выберите верное написание цикла while a=1 do while a:=1 do while a=1 to while a:=1 to...
smail520
24.04.2020 20:27
Составить программу которая образует слово языкознание в слово коза...
MaLiKaKhOn
24.04.2020 20:27
Запишите ip адрес из четырех десятичных чисел в 32-битном виде 240.198.154.20...
bumar2
05.03.2020 22:42
Напишите программу, которая вычисляет колличество цифр числа. используйте функцию. phyton...
kise1970
05.03.2020 22:41
ИНФОРМАТИКА ДАЮ ЛУЧШИЙ ОТВЕТ...
Популярные вопросы
Переходные и непереходные глаголы...
1
Какие из перечисленных и и объединение множества a и b ( 1,5,6,7,10,12,14,)...
1
Как решить 3х-(4х-11)прих=-6...
2
Определи толщину прозрачной пластинки, если световой луч проходит сквозь неё...
2
Анализ стихотворения бориса корнилова вечер...
3
Задание 2Прочитайте загадки. Выпишите глаголы 1 спряжения, затем - Глаголы...
2
Что делать, если не запускается ролблокс, а выглядит это так ПОЖАЙЛУСТА...
2
Скиньте ответы https://edu.skysmart.ru/lesson/homework/xipuluxopobi/1...
1
График функций y=7x+2 пересекает ось Оy в точке с кординатами: ( ; )...
1
Мне нужно не всё задание а только ответ на 3 и 4Даю что могу мне очень нужно...
1
x, n, max: integer;
begin
n := 0;
max := 0;
while true do
begin
read(x);
if(x mod 3 = 0)and(x<>0) then n := n + 1
else begin if(n > max) then max := n; n := 0; end;
if(x = 0) then break;
end;
write(max);
end.