Написать программу на паскале которая запрашивает трёхзначное число, затем с функций div mod разделяет число на цифры и проверяет имеются ли в введенном числе цифра "5". если да, то печатает "имеется" иначе "не имеется

supernogai supernogai    1   14.09.2019 12:40    2

Ответы
Тролечка Тролечка  07.10.2020 14:14
Var N, k, y: integer;
begin
  write('Введите число: ');
  readln(N);
  k := 0;
  repeat
    y := N mod 10;
    if y = 5 then k := k + 1;
    N := N div 10;
  until N = 0;
  if k <> 0 then writeln('Имеется')
  else writeln('Не имеется')
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика