Написать программу на паскале, которая выводит число a в обратном порядке

kkazyna kkazyna    3   04.10.2019 18:20    5

Ответы
dmitriy1978 dmitriy1978  09.10.2020 20:11

Код к задаче: «Вывести число в обратном порядке - Pascal»

var x1,x2,h,i,s:integer;

begin

write('x1=');readln(x1);

write('h=');readln(h);

x2:=2*x1+h;

i:=2;

s:=x1+x2;

while i<=8 do

begin

 i:=i+1;

 x1:=x2;

 x2:=2*x1+h;

 s:=s+x2;

 if i=5 then writeln('Пятый элемент=',x2);

 if i=7 then writeln('Сумма=',s);

 if i=8 then write('Восьмой элемент=',x2);

end;

readln

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика