Написать программу на паскале, которая вычислит точки пересечения двух функций.

Def228yufdd Def228yufdd    1   24.04.2019 02:00    2

Ответы
Дрррррррррр Дрррррррррр  08.06.2020 13:27

ax^2 +bx+c=y
y=kx+q*

 

ax^2 + bx + c = kx + q
ax^2 + (b - k) x + (c - q) = 0

 

var
a, b, x, k, q, D : real;
begin
read (a, b, x, k, q);

D := sqr ((b - k)) - 4 * a * (c - q);
if D < 0 then writeln ('Нет перечечений')
else
begin
writeln (((k - b) + sqrt (D)) / (2 * a));
writeln (((k - b) - sqrt (D)) / (2 * a));
end;
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика