Написать программу на паскале, которая определяет, есть ли среди цифр натурального числа n цифра k.

ПрофиЗнания ПрофиЗнания    2   28.01.2021 17:50    18

Ответы
Bauer322 Bauer322  28.01.2021 18:00

program NK;

var

K, N: integer;

begin

write('Число N: ');

readln(N);

write('Цифра К: ');

readln(K);

while (N <> 0) do

begin

if ((N mod 10) = K) then

begin

writeln('Есть');

halt;

end;

N := N div 10;

end;

writeln('Нет');

readln;

end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика