tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу на паскале,
Написать программу на паскале, которая будет считать сумму и среднее арифметическое 10 чисел, введенных массивом, используя процедуры или функции
axdv
2 22.09.2019 02:40
10
Ответы
МаринаБалыгина505212
08.10.2020 08:34
//Язык Pascal
Program Test;
var
Mas: array[1..10] of integer;
result1: integer;
result2: real;
function Sum(): integer;
var summa: integer;
begin
summa := 0;
for var i := 1 to 10 do
summa := summa + Mas[i];
Sum := summa;
end;
procedure Arifmetic(r1: integer; var A: real);
begin
A := r1 / 10;
end;
Begin
for var i := 1 to 10 do
begin
Write('Введите ', i, ' элемент: ');
Readln(Mas[i]);
end;
result1 := Sum();
Arifmetic(result1, result2);
Writeln();
Writeln('Сумма = ', result1);
Writeln('Среднее арифметическое = ', result2);
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Danielufa
23.10.2020 12:49
Светодиодная панель содержит шесть излучающих элементов, каждый из которых может светиться или красным, или желтым, или зелёным цветом. Сколько различных сигналов можно передать...
LeraKruspe
23.10.2020 12:49
5. Операционная система - это... * сериисовокупность всех программ, записанных на винчестерсовокупность управляющих и прикладных программсовокупность приложений Word, Excel,...
olesya12let
23.10.2020 12:50
напишите только правильные ответы...
green121
23.10.2020 12:50
N=128 слолько это i бит? 7 класс...
Андрюша1789
23.10.2020 12:50
1.Запишите беззнаковое представление десятичного числа 71 в восьмиразрядной ячейке. 2.Запиши число -34 в восьмиразрядном представлении и шестнадцати разрядах...
Grister555
23.10.2020 12:50
Переведите число в двоичную систему счисления ...
Розочка2018
12.04.2021 13:22
Значение выражения (A∧B)~(¬B → ¬A)) истинно при Выберите один или несколько ответов: 1) A=1 и B=1 2) A=0 и B=1 3) A=0 и B=0 4) A=1 и B=0...
lordczar95
14.04.2021 23:04
Створіть вікно із заголовком «Кнопки», в якому поруч розмістіть 2 кнопки. На першу кнопку додайте зображення на ваш вибір, на другу кнопку додайте текст «Кнопка 2». При натисненні...
20AKE04
14.04.2021 23:05
Таблица в ексел продолжите выполнение проектного задания.Продолжите выполнение проектного задания. В таблице Оплата электроэнергии (задание 6 из § 21) используйте абсолютный...
veronikadedylia
14.04.2021 23:05
Напишіть функцію, яка зчитує з клавіатури числа і перемножує їх, поки не буде введений 0. Функція повинна повертати отримане добуток. Викличте функцію і виведіть на екран...
Популярные вопросы
Чему равно напряжение на участке цепи АВ, если сила тока через резистор...
2
В закрытом помещении при температуре воздуха 40 °С конденсация паров воды...
3
Гиря массой 2 кг подвешена на тонком шнуре длиной 5 м. Если её отклонить...
3
Среднее расстояние между центрами Луны и Земли примерно 60 земных радиусов....
1
Пуля массой m = 10 г, летящая со скоростью v1 = 200 м/с, пробивает доску...
1
Тело массой 3 кг под действием силы F перемещается вниз по наклонной плоскости...
2
Идеальная тепловая машина работающая по циклу Карно, совершает за один...
2
Определить сопротивление цепи после замыкания ключа К...
3
Задана зависимость скорости гармонических колебаний математического маятника...
2
Период полураспада атомов изотопа кобальта 60 27Со составляет Т = 5,2...
3
Program Test;
var
Mas: array[1..10] of integer;
result1: integer;
result2: real;
function Sum(): integer;
var summa: integer;
begin
summa := 0;
for var i := 1 to 10 do
summa := summa + Mas[i];
Sum := summa;
end;
procedure Arifmetic(r1: integer; var A: real);
begin
A := r1 / 10;
end;
Begin
for var i := 1 to 10 do
begin
Write('Введите ', i, ' элемент: ');
Readln(Mas[i]);
end;
result1 := Sum();
Arifmetic(result1, result2);
Writeln();
Writeln('Сумма = ', result1);
Writeln('Среднее арифметическое = ', result2);
End.