Написать программу на паскале к
ученик 9 класса к уроку должен выучить наизусть три первые строфы первой главы романа а, с. пушкина «евгений онегин», содержащие 42 строки. сколько ему потребуется времени на выполнение этого , если первую строку он может запомнить за 5 секунд, а на запоминание каждой следующей строки ему требуется времени на 2 секунды больше, чем на запоминание предыдущей строки?

антонl антонl    3   16.09.2019 12:12    100

Ответы
Toprangdheb Toprangdheb  07.10.2020 19:40

Var str , time, thtime: integer;

Begin

str := 42;

thtime := 5;

While str>0 Do

Begin

str := str-1;

time := thtime+time;

thtime := thtime+2;

End;

write(time,' секунд');

End.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика

Популярные вопросы