Написать программу на паскале известен рост каждого ученика в классе.рост мальчиков условно задан отрицательными числами. определить средний рост мальчиков и средний рост девочек.

Madi74153 Madi74153    3   23.08.2019 19:00    3

Ответы
Zippergorskii Zippergorskii  05.10.2020 15:16
Var n, i, growth, growth_girls, growth_boys, count_boys, count_girls: integer;
begin
writeln('Введите количество учеников в классе');
read(n);

growth_girls := 0;
growth_boys := 0;
count_boys := 0;
count_girls := 0;
for i := 1 to n do
begin
  read(growth);
  if (growth < 0) then
  begin
    growth_boys := growth_boys - growth;
    count_boys := count_boys + 1;
  end
  else
  begin
    growth_girls := growth_girls + growth;
    count_girls := count_girls + 1;
  end;
end;

if (count_boys = 0) then
  writeln('В классе нет мальчиков')
else
  writeln('Средний рост мальчиков: ', (growth_boys / count_boys):0:2);

if (count_girls = 0) then
  writeln('В классе нет девочек')
else
  writeln('Средний рост девочек: ', (growth_girls / count_girls):0:2);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика