Написать программу на паскале, используя вместо for - while. ! 1. напишите программу, которая в последовательности из 12 натуральных чисел определяет минимальное чётное число. программа получает на вход натуральные числа. в последовательности всегда имеется чётное число. введённые числа не превышают 30 000. программа должна вывести одно число – минимальное чётное число. 2. напишите программу, которая в последовательности из 12 натуральных чисел определяет максимальное число, оканчивающееся на 2. программа получает на вход натуральные числа. введённые числа не превышают30 000. программа должна вывести одно число – максимальное число, оканчивающееся на 2.

molokomo molokomo    2   19.06.2019 06:40    6

Ответы
Kate905 Kate905  15.07.2020 16:27
1) 
 var
    a ,i,min: integer;
begin
min := 30000;
 i := 0;
 while i <> 12 do
  begin
   readln(a);
   if (a<min) and (a mod 2 = 0) then
    min := a;
   i := i +1;
  end;
writeln (min);
end.

2)
 var   
a ,i,max: integer;
begin
max := 0;  i := 0; 
while i <> 12 do 
begin   
readln(a);   
if (a>max) and (a mod 10 = 2) then   
max := a;   
i := i +1; 
end;
writeln (max);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика