Написать программу на паскале если данное число х меньше нуля, то z присвоить значение большего из 2 чисел х и у, иначе z присвойте значение полсуммы этих чисел.

vigolnikov vigolnikov    2   20.05.2019 13:40    6

Ответы
inga50 inga50  13.06.2020 23:52

  Program Z;

Uses Crt;

var x,y,z:real;

begin

    clrscr;

    write('Введите х: ');

    readln(x);

    write('Введите y: ');

    readln(y);

    if (x<0)  and (x>y) then z:=x;

    if (x<0)   and (x<y) then z:=y;        

 

    if (x>=0) then z:=(x+y)/2;

    writeln('z=',z);

   readkey;

 

end. 

 

 

 

 

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика