Написать программу на паскале для определения числа членов ряда,вошедших в сумму.исходные данные 0.62,точность вычисления 10^-4.

zhirola2013 zhirola2013    2   11.08.2019 12:10    2

Ответы
liliyamukhamad liliyamukhamad  31.08.2020 13:52
Const eps=1e-4;
var n,z:integer; x,sx,an,s:real;
begin
x:=0.62;
sx:=sin(x);
n:=1; z:=-1; 
an:=1; s:=0;
while abs(an)>eps do
 begin
 z:=-z;
 n:=n+1;
 an:=z*sx/(n*(n*n-1));
 s:=s+an;
 end;
writeln('k = ',n-1,' s = ',s);
end.

Результат:
k = 17 s = 7.92376332816429E-002
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика