tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу на паскале:
Написать программу на паскале: для х=3, 11, 19, 27, … (всего 73 значения х) вычислить и напечатать y=sinx+1
ASTRA5555
1 31.07.2019 04:00
3
Ответы
fanaidap
03.10.2020 18:14
var
i, x:integer;
begin
x:=3;
for i:=1 to 73 do
begin
writeln(sin(x)+1);
x:=x+8;
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
tatianafirstovp06ovw
03.10.2020 18:14
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
begin
SeqGen(73,3,x->x+8).Tabulate(x->sin(x)+1).Println(NewLine)
end.
Результат
(3,1.14112000805987)
(11,9.79344929652459E-06)
(19,1.14987720966295)
(27,1.9563759284045)
(35,0.571817330503849)
(43,0.168225257371402)
(51,1.67022917584337)
(59,1.63673800713914)
(67,0.144480021024678)
(75,0.61221836459057)
(83,1.96836446110019)
(91,1.10598751175116)
(99,0.000793165813646302)
(107,1.18478174456067)
(115,1.94543533402477)
(123,0.540096509310409)
(131,0.1883966128633)
(139,1.69608013122474)
(147,1.60904402188329)
(155,0.126688017225352)
(163,0.645089824155065)
(171,1.97659086794357)
(179,1.07072216723899)
(187,0.00282897660785097)
(195,1.21945466799406)
(203,1.93330970016696)
(211,0.508952146149537)
(219,0.209585258506819)
(227,1.72105859707063)
(235,1.58058664098964)
(243,0.109990651143723)
(251,0.678406139707496)
(259,1.98359318394668)
(267,1.03536817725618)
(275,0.00611467408027389)
(283,1.25385251979023)
(291,1.92001422549596)
(299,0.47842327838163)
(307,0.231764635762553)
(315,1.74513326455741)
(323,1.55140153386739)
(331,0.0944088518029327)
(339,0.712125551491514)
(347,1.98936263217831)
(355,0.999969855646641)
(363,0.0106461398305572)
(371,1.28793218456003)
(379,1.9055655749933)
(387,0.448548171885085)
(395,0.254906944275786)
(403,1.76827395771179)
(411,1.52152528208153)
(419,0.0799621499383943)
(427,0.746205794496806)
(435,1.9938919810239)
(443,0.96457157182102)
(451,0.0164176939717596)
(459,1.32165094574031)
(467,1.88998185906867)
(475,0.419364273092607)
(483,0.278983176722363)
(491,1.79045167123434)
(499,1.49099533350029)
(507,0.0666686535173281)
(515,0.780604151435442)
(523,1.9971755532499)
(531,0.929217695142592)
(539,0.0234221022497116)
(547,1.35496653913623)
(555,1.87328261085979)
(563,0.390908162054621)
(571,0.303963155167414)
(579,1.81163860685574)
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
DayanaTolepber
31.05.2019 15:50
Задали написать про телефон краткое сообщение(типо кто его создал,когда,зачем ляля),я не знаю что писать вообще...
msajkina
14.05.2020 17:54
Язык программиривания - Python Количество различных элементов — 2 Дан список. Посчитайте, сколько в нём различных элементов, не изменяя самого списка. Входные данные...
Kiralex71
14.05.2020 17:54
Компьютерная презентация – это … 1) прикладная программа для представления какой-либо информации 2) набор картинок для представления какой-либо информации 3) электронный...
вова985
11.02.2021 09:28
5. Определите типы данных в характеристиках автомобиля. Правильный ответ подчеркните линией.Пример: Тип кузова - седан. вештественный строковый/логический...
lesikviktoria47
11.02.2021 09:27
Дана программа для решения задачи. определи и запиши результат выполнения программы при...
kamilaiks466
11.02.2021 09:27
Определи соответствующую фигуру, для которой найдена площадь. s=(r**2*pi)/2. Рис. 4 Рис. 3...
TatarskayaGreckha
15.07.2019 09:41
Сследующим : есть массив items класса который содержит в себе имя и количество, необходимо найти массив с именем apple с количеством в себе 5 и изменить в двух...
Nastykaramova
15.07.2019 09:36
ответ не сходится программа печатает два числа a, b. указать наименьшее х, при вводе которого программа печатает сначала 3, а потом 10. x = int( a = 0 b = 1 while...
414484
15.07.2019 09:31
Программа запрашивает число n. далее, мы вводим n чисел и сохраняем все введенные числа в массив. выведите в конце только положительные элементы. ввод: 10 6 19...
mariuaivanova1
21.06.2019 00:50
10 пословиц с противительными союзами...
Популярные вопросы
Цену нужно знать на автомобиль...
1
Жазбаша/Письменно 1-тапсырма. Мәтін бойынша 5 сұрақ құрастырып...
1
Название памятника Вопросы 1 Где расположен? 2 Кто исследовал?...
3
Прочитай стихотворение подчеркни в нём только те выделенные...
1
3. Охарактеризуйте движение частиц в газах и их вза имодействие....
2
Берілген сөздің мағнасын анықтаңыз.Тапсырманы орындау үшін түсіндірме...
1
Что объединяет приведённые ниже понятия? Дайте максимально точный...
3
Сколько было походов скоко мне чиртить 4 или сколько походов...
3
Ребята химия Укажите массу (г) вещества, образующегося при поглощении...
1
Діагональ прямокутного паралелепіпеда на 1 см більша за його...
1
var
i, x:integer;
begin
x:=3;
for i:=1 to 73 do
begin
writeln(sin(x)+1);
x:=x+8;
end;
end.
begin
SeqGen(73,3,x->x+8).Tabulate(x->sin(x)+1).Println(NewLine)
end.
Результат
(3,1.14112000805987)
(11,9.79344929652459E-06)
(19,1.14987720966295)
(27,1.9563759284045)
(35,0.571817330503849)
(43,0.168225257371402)
(51,1.67022917584337)
(59,1.63673800713914)
(67,0.144480021024678)
(75,0.61221836459057)
(83,1.96836446110019)
(91,1.10598751175116)
(99,0.000793165813646302)
(107,1.18478174456067)
(115,1.94543533402477)
(123,0.540096509310409)
(131,0.1883966128633)
(139,1.69608013122474)
(147,1.60904402188329)
(155,0.126688017225352)
(163,0.645089824155065)
(171,1.97659086794357)
(179,1.07072216723899)
(187,0.00282897660785097)
(195,1.21945466799406)
(203,1.93330970016696)
(211,0.508952146149537)
(219,0.209585258506819)
(227,1.72105859707063)
(235,1.58058664098964)
(243,0.109990651143723)
(251,0.678406139707496)
(259,1.98359318394668)
(267,1.03536817725618)
(275,0.00611467408027389)
(283,1.25385251979023)
(291,1.92001422549596)
(299,0.47842327838163)
(307,0.231764635762553)
(315,1.74513326455741)
(323,1.55140153386739)
(331,0.0944088518029327)
(339,0.712125551491514)
(347,1.98936263217831)
(355,0.999969855646641)
(363,0.0106461398305572)
(371,1.28793218456003)
(379,1.9055655749933)
(387,0.448548171885085)
(395,0.254906944275786)
(403,1.76827395771179)
(411,1.52152528208153)
(419,0.0799621499383943)
(427,0.746205794496806)
(435,1.9938919810239)
(443,0.96457157182102)
(451,0.0164176939717596)
(459,1.32165094574031)
(467,1.88998185906867)
(475,0.419364273092607)
(483,0.278983176722363)
(491,1.79045167123434)
(499,1.49099533350029)
(507,0.0666686535173281)
(515,0.780604151435442)
(523,1.9971755532499)
(531,0.929217695142592)
(539,0.0234221022497116)
(547,1.35496653913623)
(555,1.87328261085979)
(563,0.390908162054621)
(571,0.303963155167414)
(579,1.81163860685574)