Написать программу на паскале: даны 3 числа в порядке возрастания-стороны треугольника, вывести сообщение «этот треугольник прямоугольный» решается полугодовая 46

сева167 сева167    1   05.10.2019 20:20    3

Ответы
vera0503 vera0503  09.10.2020 22:24

var a,b,c: integer;

writeln ('введите стороны прямоугольника')

readln(a,b,c);

if a*a+b*b=c*c than writeln ('этот треугольник прямоугольный') else writeln ('этот треугольник не прямоугольный');

end.

ПОКАЗАТЬ ОТВЕТЫ
ramilienozxqke ramilienozxqke  09.10.2020 22:24

label ra,rb;

var a,b,c: integer;

begin

write('Введите сторону a: ');

readln(a);

ra: write('Введите сторону b: ');

readln(b);

if b>a then

begin

rb: write('Введите сторону c: ');

readln(c);

if c>b then begin

if sqr(c)=sqr(a)+sqr(b) then writeln('Этот треугольник - прямоугольный') else writeln('Этот треугольник - не прямоугольный');

end else begin writeln('Введите число больше, чем ',b); goto rb; end;

end else begin writeln('Введите число больше, чем ',a); goto ra; end;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика