Написать программу на паскале: даны 3 числа, если это куб-найти объём, если это параллелепипед-найти площадь поверхности

Potterhead01 Potterhead01    1   05.10.2019 20:30    2

Ответы
nikita11111113 nikita11111113  09.10.2020 22:32

var a,b,c,k: real;

begin

write('Введите 1 число: ');

readln(a);

write('Введите 2 число: ');

readln(b);

write('Введите 3 число: ');

readln(c);

if (a=b) and (b=c) and (a=c) then

begin

k:=a*b*c;

writeln('Объем куба равен ',k);

end else

begin

k:=2*(a*b+b*c+a*c);

writeln('Площадь поверхности параллелипипеда равна ',k);

end;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика