Написать программу на паскале даны 2 массива. элемент одного массива умножить на элемент другого в обратном порядке. заранее

nastusya0307 nastusya0307    3   24.06.2019 21:00    1

Ответы
HelloyKiss HelloyKiss  20.07.2020 09:48
Const
  n = 8;

var
  a,b: array[1..n] of integer;
  i, k, s: integer;

begin
  Randomize;
  Write('Массив 1:  ');
  for i := 1 to n do
  begin
    a[i] := Random(50)+1;
    Write(a[i]:5);
  end;
  Writeln;
  Write('Массив 2:  ');
  for i := 1 to n do
  begin
    b[i] := Random(50)+1;
    Write(b[i]:5);
  end;
  Writeln;
  Write('Результат: ');
  for i := 1 to n do Write(a[i]*b[n-i+1]:5);
  Writeln
end.

Тестовое решение:
Массив 1:     39   10   14   23   37   38   33   48
Массив 2:     22   45    1   17   16   42   21   39
Результат:  1521  210  588  368  629   38 1485 1056
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика