Написать программу на паскале: дана s круга. найти его диаметр d и длину l окружности, ограничивающей этот круг, учитывая, что l = π×d, s = π×d2(в квадрате) /4

Vareniki0513 Vareniki0513    2   30.09.2019 23:00    3

Ответы
bon1101 bon1101  04.08.2020 20:28

const

 pi = 3.14;

var

 S, D, L: real;

begin

 write('Введите площадь круга: S = ');

 readln(S);

 D := 2 * sqrt(S / pi); { <-- Вычисляем диаметр круга }

 L := pi * D; { <-- Вычисляем длину окружности }

 writeln('Результат:');

 writeln(' D = ', D:0:2); { <-- Выводим диаметр на экран }

 writeln(' L = ', L:0:2); { <-- Выводим длину на экран }

 readln

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика