Написать программу на Паскале Дан массив A целых чисел, содержащий 30 элементов. Вычислить и вывести сумму
тех элементов, которые нечетны и отрицательны.

mistrgeniy mistrgeniy    2   22.05.2021 22:54    5

Ответы
vasa2283 vasa2283  21.06.2021 23:54

const

 n=30;

var

 a:array [1..n] of integer;

 i,sum:integer;

begin

 sum:=0;

 for i:=1 to n do

   begin

     a[i]:=random(101)-50;

     if (abs(a[i] mod 2) = 1) and (a[i]<0) then

       sum:=sum+a[i];

     write(a[i]:4);

   end;

 writeln;

 write('sum: ',sum);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика