Написать программу на паскале. дан двумерный массив размером 5 * 5 элементы массива вводятся пользователем вручную. составьте программу определения индексов минимального элемента этого массива. полученный результат вывести на экран.

anna1870 anna1870    3   02.09.2019 18:10    2

Ответы
stasya10687 stasya10687  06.10.2020 12:53
Const 
n=5;
var 
a: array[1..n,1..n] of integer; 
i,j,im,jm: integer;

begin 
writeln('Массив:'); 
for i:=1 to n do 
begin   
for j:=1 to n do   
begin     
read(a[i,j]);   
end; 
end; 
writeln;   

im:=1; jm:=1; 
for i:=1 to n do   
for j:=1 to n do     
if a[i,j]<a[im,jm] then     
begin       
im:=i;       
jm:=j;     
end; 
writeln('Минимум = ',a[im,jm]); 
writeln('Строка: ',im,'  столбец: ',jm); 
readln;
end.
ПОКАЗАТЬ ОТВЕТЫ
tryx3 tryx3  06.10.2020 12:53
// PascalABC.NET 3.2, сборка 1467 от 02.06.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('Введите 25 целочисленных элементов массива');
  var a:=ReadMatrInteger(5,5);
  var t:=a.ElementsWithIndexes.MinBy(x->x[2]);
  Writeln('Min=A[',t[0]+1,',',t[1]+1,']=',t[2])
end.

Пример
Введите 25 целочисленных элементов массива
-32 75 16 1 52
26 -41 -96 -67 79
-20 27 -38 -42 -92
-8 -1 30 -76 -56
95 -95 -11 20 70
Min=A[2,3]=-96
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика