, написать программу на паскале. Цель следующая: Найти количество единиц и количество нулей во введенном натуральном числе.
Желательно использовать циклы while и repeat.

ник4410 ник4410    3   19.10.2021 01:11    5

Ответы
madamburkova20 madamburkova20  19.10.2021 01:20

1038 врод использовать циклы while и repeat не стал поэтому может быть неправильно

ПОКАЗАТЬ ОТВЕТЫ
наргиз68 наргиз68  19.10.2021 01:20

var

N, _counterZ, _counterU : integer;

begin

_counterU := 0;

_counterZ := 0;

readln(N);

while N > 0 do

   begin

   if N mod 10 = 1 then

       _counterU := _counterU + 1;

   if N mod 10 = 0 then

       _counterZ := _counterZ + 1;

   N := N div 10;

   end;

writeln('Количество единиц в числе: ', _counterU);

writeln('Количество нулей в числе: ', _counterZ);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика