Написать программу на паскале авс. дана строка,в которой есть точки,запятые,пробелы,тире,слова. в общем,много-много всего. нужно преобразовать строку по правилам ворда. то есть 1.между словами один пробел 2.перед точкой или запятой пробела нет,но после-есть 3. тире выделяется пробелами с двух сторон вот и все!

julia00221 julia00221    3   03.08.2019 05:10    0

Ответы
vustiya69 vustiya69  03.10.2020 20:27
Var s,s1:string; i,p:integer;
begin
writeln('Введите строку:');
readln(s);
s1:='';
for i:=1 to length(s) do
 case s[i] of
 ',','.' : s1:=s1+s[i]+' ';
 '-'     : s1:=s1+' - ';
 else s1:=s1+s[i];
 end;
p:=pos('  ',s1);
while p>0 do
 begin delete(s1,p,1); p:=pos('  ',s1); end;
p:=pos(' ,',s1);
while p>0 do
 begin delete(s1,p,1); p:=pos(' ,',s1); end;
p:=pos(' .',s1);
while p>0 do
 begin delete(s1,p,1); p:=pos(' .',s1); end; 
writeln(s1);
end.

Пример:
Введите строку:
перед точкой   или   запятой пробела нет   ,но после   -есть   .
перед точкой или запятой пробела нет, но после - есть. 
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика