Написать программу на паскале абс цикл с постусловием дано целое число n (> 1). вывести наименьшее из целых чисел k, для которых сумма 1 + 2 + … + k будет больше или равна n, и саму эту сумму.

Katya4polua Katya4polua    3   17.07.2019 04:50    4

Ответы
dasha50052 dasha50052  03.10.2020 06:12
Var n,k,summ:integer;
begin
  write('Введи число N: ');
  readln(n);
  repeat begin
     k:=k+1;
     summ:=summ+k;
     end;
  until summ>=n;
  writeln('K=',k,', 1+..+',k,'=',summ,', ',summ,'>=',N);
end.  
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика