Написать программу на паскале 1.написать функцию,подсчитывающую количество единиц в числе и с её определить,в каком из двух чисел единиц больше.

ZABENOK123 ZABENOK123    2   07.08.2019 20:20    1

Ответы
kirstav64 kirstav64  04.10.2020 03:38
Var
  s, s2: string;

 function one(s: string): integer;
var i, c: integer;
begin
  c := 0;
  for i := 1 to length(s) do
    if (s[i] = '1') then c := c + 1;
  result := c;
end;

 begin
  writeln('Введите первое число:');
  readln(s);
  writeln('Введите второе число:');
  readln(s2);
  if(one(s) > one(s2)) then write('В первом числе больше единиц')
  else write('Во втором числе больше единиц');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика