Написать программу на паскаль в целочисленной последовательности есть нулевые элементы создать новый массив из номеров этих элементов.массив задан программой.dat[1]=0 dat[6]=0dat[2]=13 dat[7]=17dat[3]=79 dat[8]=0dat[4]=23 dat[9]=0dat[5]=0 dat[10]=10

Yuki16 Yuki16    3   08.10.2019 17:40    7

Ответы
prostofiii prostofiii  10.10.2020 04:52

var Dat:array [1..10] of integer;

i,k,j:integer;

a:array [1..10] of integer;

BEGIN

Dat[1]:=0;

Dat[2]:=13;

Dat[3]:=79;

Dat[4]:=23;

Dat[5]:=0;

Dat[6]:=0;

Dat[7]:=17;

Dat[8]:=0;

Dat[9]:=0;

Dat[10]:=10;

j:=1;

k:=0;

for i:=1 to 10 do

if (Dat[i]=0) then begin

a[j]:=i;

k:=k+1;

j:=j+1;

end;

for j:=1 to k do

write(a[j],' ');

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика