Написать программу на паскаль напиши программу ,которая вводит десять чисел в одномерный массив ,а затем складывает по модулю отдельно все положительные элементы этого массива ,отдельно отрицательные элементы и находит разницу между ними и выдает полученные на экран через файл

Элинка235 Элинка235    1   27.08.2019 14:20    19

Ответы
лена363 лена363  05.10.2020 22:53
Var arr: array [1..10] of integer;
var i,sum,sum1:integer;
begin
for i:=1 to 10 do begin
writeln('Введите ',i,' элемент');
readln(arr[i]);
end;
sum:=0;
sum1:=0;
for i:=1 to 10 do begin
if (arr[i]>0) then begin
sum:= sum + arr[i];
end
else
if (arr[i]<0) then begin 
sum1:= sum1 + arr[i];
end;
end;
writeln('Сумма положительных равна ',sum);
writeln('Сумма отрицательных равна ',sum1);
writeln('Разница равна ',sum-sum1);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика