Написать программу на pascalabc создать программу: "вводится n чисел. найти среднее арифметическое всех нечетных, кратных 3 чисел.

Salkin355 Salkin355    3   16.07.2019 18:30    2

Ответы
aldynsaioorzhak1 aldynsaioorzhak1  21.09.2020 12:23
// PascalABC.NET 3.0, сборка 1150 от 22.01.2016
begin
  var n:=ReadInteger('n=');
  var s:=0;
  var k:=0;
  var m:integer;
  for var i:=1 to n do begin
    Read(m);
    if Odd(m) and (m mod 3 = 0) then begin
      s+=m; Inc(k)
      end
    end;
  if k>0 then Writeln(s/k)
  else Writeln('Нет чисел, удовлетворяющих условию')
end.

Тестовое решение:
n= 10
6 3 12 15 -9 11 0 14 42 11
3
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика