написать программу на PascalABC.NET Нужно подсчитать количество студентов младше 16 лет, и вывести все данные о них

СнежанаВолк СнежанаВолк    2   10.01.2021 22:11    4

Ответы
danil7531 danil7531  09.02.2021 22:11

var

 nm,snm:array of string;

 age:array of integer;

 k,s:integer;

begin

 

 write('Введите общее кол-во студентов - '); readln(k);

 setLength(nm,k); setLength(snm,k); setLength(age,k);

 for var i1:=0 to k-1 do begin

   writeln('[Студент ',i1+1,']');

   write('Имя     - '); readln(nm[i1]);

   write('Фамилия - '); readln(snm[i1]);

   write('Возраст - '); readln(age[i1]);

 end;

 

 for var i2:=0 to k-1 do

   if age[i2]<16 then s:=s+1;

 

 writeln; writeln('Кол-во студентов которым меньше 16 лет = ',s,' человек:');

 for var i2:=0 to k-1 do begin

   if age[i2]<16 then writeln(nm[i2],' ',snm[i2],' ',age[i2],' лет');

 end;

 

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика