Написать программу на pascal, либо c++ и составить блок-схему даны натуральные числа a1, признак конца последовательности 99. найти количество положительных чисел и удвоенное количество отрицательных чисел.

Ailina24 Ailina24    3   26.09.2019 22:50    3

Ответы
777stepan777 777stepan777  11.08.2020 07:48

Подключи библиотеки iostream и Windows.h


int main() {

int nNumsCount = 0,

pNumsCount;

int number = 0;

while(std::cin >> number && number != 99){

if(number < 0)

++nNumsCount;

if(number > 0)

++pNumsCount;

}

std::cout << pNumsCount << '\n' << 2*nNumsCount << std::endl;

system("pause");

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика