Написать программу на pascal, которая определяет, существует ли треугольник со сторонами a,b,c,зная, что сумма двух сторон треугольника всегда больше третьей

незнайка3333333333 незнайка3333333333    2   26.05.2019 22:47    3

Ответы
Dimon22872 Dimon22872  23.06.2020 16:16

program raf105;

var

 a,b,c: integer;

 x: boolean;

begin

 x:= True;

 write('Введите 3 числа через пробел: ');

 readln(a,b,c);

 if a+b < c

   then x:= False;

 if a+c < b

   then x:= False;

 if b+c < a

   then x:= False;

 if x

   then writeln('Треугольник существует')

   else writeln('Треугольника не существует');

end.

PascalABC 3.4.2
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика