Написать программу на pascal из трехзначного числа x вычли его последнюю цифру. когда результат разделили на 10, а к частному слева приписали последнюю цифру числа x. то получилось число n. по заданному n найти число x (значение n вводится с клавиатуры, 10< =n< =999 , и при этом число десятков в n не равно нулю).

irajuta82 irajuta82    3   09.08.2019 03:30    20

Ответы
buzaeva2013 buzaeva2013  04.10.2020 06:29
Если было число ABC = X, то после деления на 10 стало AB, а после приписывания слева CAB = N. Для получения из N числа X просто переставляем первую цифру в конец.

var
  N: integer;

begin
  readln(N);
  write(10 * (N mod 100) + (N div 100))
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика