Написать программу на pascal ( из гиа). заранее огромное . напишите программу, которая в последовательности натуральных чисел определяет максимальное число оканчивающееся на 3. количество чисел не превышает 1000. введённые числа не превышают 30 000. программа должна вывести одно число - максимальное число, оканчивающееся на 3.

arinasmail1 arinasmail1    1   22.05.2019 02:50    2

Ответы
temik2005ap08ttx temik2005ap08ttx  17.06.2020 03:27

uses crt;
var a:array[1..1000] of integer;
i,max,n:integer;
begin
clrscr;
write('n<1000, n=');
read(n);

writeln('a[i]<30000, a[i]:');
for i:=1 to n do
begin
readln(a[i]);
if (a[i] mod 10=3) and (a[i]>max) then max:=a[i];
end;
write('max=',max);
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика