Написать программу на pascal, используя рекурсию: дан набор символов, оканчивающихся пробелом (короче это слово), вывести символы в обратном порядке, используя рекурсию.

arinashabalina1 arinashabalina1    3   19.08.2019 03:40    1

Ответы
ekhalyavin ekhalyavin  05.10.2020 04:02
Var s: string;
procedure PrintChar(s:string;n:integer);
begin
    if s[n]<>' '
     then begin PrintChar(s,n+1); write(s[n]); end;
end;
begin
    write('Введите слово: ');
    readln(s);
    PrintChar(s,1);
end.

Пример:
Введите слово: телефон 
нофелет
ПОКАЗАТЬ ОТВЕТЫ
polina5m polina5m  05.10.2020 04:02
Program pos;
var
    s: string;
    l: integer;
procedure PrintChar(n: integer);
var
    sub: string;
begin
    sub := Copy(s, n, 1);
    write(sub);
    if n <> 1 then
        PrintChar(n - 1);
end;
begin
    write('Введите слово: ');
    readln(s);
    l := Length(s);
    PrintChar(l);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика