Написать программу: на концерте было k зрителя. из них k1 человек купили билеты по c1 рублей, а остальные-по с2 рублей. сколько денег (sum) было выручено от продажи билетов? (к=894 чел., к1=396 чел., с1=150 рублей, с2=200 рублей) объясните принцип действия оператора sum, не был на уроке, а ничего дельного не нашел

элина20072 элина20072    1   01.04.2019 12:10    1

Ответы
Мейвис00 Мейвис00  28.05.2020 05:33

Тут и обяснять особо нечего. Сначала вычесляем сколько было "остальных" зрителей, потом общую сумму от продажи k1 человекам, потом общую сумму от продажи k2(остальным) человекам, то и то складываем и присваиваем переменной sum.

program test;
var k, k1, k2, c1, c2, sum: integer;
begin
   k:=894;
   k1:=396;
   c1:=150;
   c2:=200;
   k2:=k-k1;
   sum:=k1*c1 + k2*c2;
   writeln('Sum = ', sum, ' rub');
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика