Написать программу на ! дана прямоугольная матрица размером . определить номер строки, сумма элементов которой максимальна, и поменять местами эту строку и последнюю строку матрицы. если данная строка оказалась последней, выдать на экран сообщение, о том, что менять строки местами не нужно.

keniwo keniwo    3   31.03.2019 11:30    4

Ответы
TemaKorol190803ru TemaKorol190803ru  27.05.2020 22:27

На входе вводим с клавиатуры размерность массива: n строк и m столбцов.

Первые два вложенных цикла - это ввод двумерного массива с датчика случайных чисел randomize.

Далее во вложенных циклах ищем максимальную сумму элементов по строкам и запоминаем номер строки в переменную k.

Строку с выводом s и k писать не нужно.

Далее один цикл обмена к-той строки и последней.

Последние вложенные циклы выводят изменённый массив.

Прежде чем выводить массив нужно поставить поверку:

If k=m then write(‘Менять строки местами не нужно’) else begin и последние два вложенных цикла.


Написать программу на ! дана прямоугольная матрица размером . определить номер строки, сумма элемент
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика