написать программу на C#
В данной действительной квадратной матрице порядка n найти сумму элементов строки, в которой расположен элемент с наименьшим значением. Предполагается, что такой элемент единствен.

smaliar2004 smaliar2004    1   26.04.2020 19:55    11

Ответы
ЮлияТимофеева ЮлияТимофеева  13.10.2020 22:03

using System;

namespace ConsoleApp1

{

   class Program

   {

       static void Main(string[] args)

       {

           int n,i,j, imin = 0;

           double sum = 0;

           Console.Write("Введите n: ");

           n = Convert.ToInt32(Console.ReadLine());

           double[,] A = new double[n, n];

           Random r = new Random();

           for (i = 0; i < n; i++)

           {

               for (j = 0; j < n; j++)

               {

                   A[i, j] = r.NextDouble()*100 - 50;

                   Console.Write("{0,10:0.0}", A[i, j]);

                   if (A[i, j] < A[imin / 10, imin % 10]) imin = i * 10 + j;

               }

               Console.WriteLine();

           }

           i = imin / 10;

           for (j = 0; j < n; j++) sum += A[i, j];

           Console.WriteLine("Сумма элементов строки с наименьшим значением: {0,10:0.0}", sum);

       }

   }

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика