Написать программу на c# написать программу, удаляющую из записи числа все чётные цифры.

Umid3317 Umid3317    2   14.06.2019 05:30    5

Ответы
Seitowad Seitowad  02.10.2020 01:30
Static class Program
{
    public static IEnumerable<uint> Digits(this uint X, bool Reverse = true)
    {
        do { yield return X % 10; } while ((X /= 10) != 0);
    }

    static uint ToUnsignedInt32(this IEnumerable<uint> Digits)
    {
        return Digits.Reverse().Aggregate((a, d) => a * 10 + d);
    }

    static void Main()
    {
        Console.WriteLine(
            uint.Parse(Console.ReadLine())
                .Digits()
                .Where(d => d % 2 == 1)
                .ToUnsignedInt32());
                
        Console.ReadKey();
    }
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика