Написать программу на c++ которая выводит пирамиду из чисел. с клавиатуры водится число и до этого числа строится пирамида. вот как должно выглядеть(пример)

karina847 karina847    3   22.10.2019 00:25    4

Ответы
рома1325 рома1325  11.09.2020 11:24

#include <iostream>

using namespace std;

int main()

{

 int n, i, j;

 string s, c;

 cout << "N = ";

 cin >> n;

 s = string(n, ' ');

 for (i = 1; i <= n; i++) {

   cout << "\n" << s;

   s.erase(s.size() - 1);

   for (j = 1; j <= i; j++) {

     if (n <= 9)

       c = " ";

     else

       c = i <= 9 ? "  " : " ";

     cout << c << i;

   }

 }

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика