Написать программу на c++ для вывода на экран в столбик все цифры переданного ей числа , начиная с первой. пример : введите натуральное число : 1234 1 2 3 4

upf300804 upf300804    3   14.08.2019 20:00    2

Ответы
NextHelp NextHelp  04.10.2020 19:27
#include <iostream>
using namespace std;

int main()
{
    int a;
    int b =0;
    cout << "Введите натуральное число :", cin >> a, cout << "\n";
    while (a>0){
    b = b*10+(a%10);
    a = a/10;
    }
    while (b>0){
    cout << b%10 << "\n";
    b = b / 10;
    }
    return 0;
}

Пример:
Введите натуральное число : 8025
8
0
2
5
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика