Написать программу на C++ Дано: n, a[n][n]. Если на главной диагонали матрицы все элементы положительные, вычислить и вывести значение суммы элементов главной диагонали. Иначе напечатать сообщение «На главной диагонали есть отрицательные элементы».
Для решения задачи использовать динамическую память и генератор случайных чисел
p.s желательно с комментариями

Аделина2605 Аделина2605    3   28.12.2020 17:33    2

Ответы
F1Na1Ik F1Na1Ik  27.01.2021 17:33

#include <iostream>

#include <vector>

#include <cstdlib>

#include <ctime>

using namespace std;

int main() {

setlocale(LC_ALL, "Russian");

int sum = 0;

vector<vector<int>> arr;

arr.resize(10);

for (int i = 0; i < 10; ++i) {

 arr[i].resize(10);

}

for (int i = 0; i < 10; ++i) {

 for (int j = 0; j < 10; ++j) {

  arr[i][j] = rand();

  cout << arr[i][j] << " ";

  if (j == 9) {

   cout << endl;

  }

 }

}

for (int i = 0, j = 0; i < 10, j < 10; ++i, ++j) {

 if (arr[i][j] < 0) {

  cout << "На главной диагонали есть отрицательные числа...";

  return 0;

 }

 sum += arr[i][j];

}

cout << "Сумма элементов главной диагонали: ";

cout << sum;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика