Написать программу на c++(целоцисленная арифметика). найти наибольшую и наименьшую цифры в записи заданного натурального числа.

dygbejs dygbejs    3   22.07.2019 05:10    2

Ответы
kirillstetskii kirillstetskii  23.09.2020 14:03
#include <iostream>
#include <iomanip>
using namespace std;

int main() {
   int i=0,n,mn=9,mx=0,k; 
   cout<<"n = ";  cin>>n;
   while (n!=0) 
   {
      k=n % 10;
     if (k>mx)  mx=k;
     if (k<mn)  mn=k;
     n=n/10;   
   }
   cout<<"max "<<mx<<endl;
   cout<<"min "<<mn<<endl<<endl;
   system("pause");
   return(0);
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика