Написать программу на алгоритмическом языке pascal с использованием любого оператора цикла. y= система первая строчка sin(2x+1), x< =4 вторая строчка x в квадрате - корень из x, третья строчка 3ln x, x> 6 предел изменения x {3,0; 7,5} шаг 0,25

diamond1277p08lfa diamond1277p08lfa    1   03.09.2019 02:40    8

Ответы
vadyushasergee2 vadyushasergee2  06.10.2020 13:46
\displaystyle y=\left\{\begin{matrix} &#10;\sin(2x+1), &x\leqslant 4 \\ &#10;x^2-\sqrt x, &4\ \textless \ x\leqslant 6 \\ &#10;3\ln x, &x\ \textgreater \ 6 &#10;\end{matrix}\right.

// PascalABC.NET 3.2, сборка 1485 от 15.06.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var x:=3.0;
  var y:real;
  while x<=7.51 do begin
    if x<=4 then y:=Sin(2*x+1)
    else if x<=6 then y:=x*x-Sqrt(x)
    else y:=3*ln(x);
    Writeln(x:4:2,y:15:8);
    x+=0.25
    end
end.

Результат
3.00     0.65698660
3.25     0.93799998
3.50     0.98935825
3.75     0.79848711
4.00     0.41211849
4.25    16.00094719
4.50    18.12867966
4.75    20.38305053
5.00    22.76393202
5.25    25.27121215
5.50    27.90479212
5.75    30.66458424
6.00    33.55051026
6.25     5.49774439
6.50     5.61540653
6.75     5.72862751
7.00     5.83773045
7.25     5.94300441
7.50     6.04470906
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика