Написать программу которая запросит длинны трёх сторон треугольника. проверить возможность его сущ. и в предположенном результате найдёт и выведет на экран площадь один кто !

yaroslavat05 yaroslavat05    3   19.08.2019 04:10    4

Ответы
МАВ03022004 МАВ03022004  05.10.2020 04:05
Var  
a,b,c{длины сторон}, S{площадь тр.}, p{полупериметр}:double;
begin
writeln('Введите стороны треугольника:');
readln(a,b,c);
     if (a>=b+c) or (b>=a+c) or (c>=a+b) then     
     writeln ('Такого треугольника не существует')     
     else begin   
     p:=(a+b+c)/2;     
     S:=sqrt(p*(p-a)*(p-b)*(p-c)); {вычисляем S тр. по формуле Герона}     
     writeln ('Такой треугольник существует, его S = ', S, 'ед.');     
     end;     
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика