Написать программу,которая запрашивает с клавиатуры четырехзначное число и сравнивает в нём первую и последнюю цифры, вторую и третью цифры. если первая цифра равна четвёртой, а третья второй, то выводит на экран "палиндорм", а в противном случае "не палиндорм".

lana770 lana770    2   25.07.2019 17:20    3

Ответы
wertyfaq wertyfaq  15.09.2020 23:39
Var
  a:integer;
begin
  write('Введите число ');
  readln(a);
  if (a div 1000 = a mod 10) and ((a div 100)mod 10 =(a div 10)mod 10)then
  writeln('Палиндром')
  else writeln('не Палиндром');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика