Написать программу, которая запрашивает номер дня недели и выводит его название. включить в программу модуль crt. запрос и результат работы программы вывести в окнах разного цвета. установить цвет символов по желанию. pascal

академег228 академег228    1   02.09.2019 08:30    4

Ответы
Lyashchyov4777 Lyashchyov4777  06.10.2020 11:30
Uses Crt;

Procedure R(Nazvanie:string; Cvet:byte);
Begin
TextBackground(Cvet);
ClrScr;
GotoXY(WindowWidth div 2-Length(Nazvanie) div 2,WindowHeight div 2);
Write(Nazvanie);
End;

Var n:byte;
Begin
HideCursor;
TextBackground(0);
ClrScr;
TextColor(15);
GotoXY(WindowWidth div 2-12,WindowHeight div 2);
Write('Введите номер дня недели');
Case ReadKey of
'1':
    R('Понедельник',4);
'2':
    R('Вторник',14);
'3':
    R('Среда',2);
'4':
    R('Четверг',9);
'5':
    R('Пятница',1);
'6':
    R('Суббота',13);
'7':
    R('Воскресенье',12);
else R('В неделе сейчас семь дней!',0);
End;
ReadKey
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика