Написать программу, которая запрашивает кол-во сотен, кол-во десятков, кол-во единиц, затем записывает соответствующее число, а также сумму квадратов его цифр. сделать в программе pascalabc.net

35546600 35546600    3   25.07.2019 13:40    2

Ответы
viktorvipp0aa6w viktorvipp0aa6w  19.08.2020 16:54
Program test;
var
a,b,c,d,n:integer;
begin
Writeln('Введите кол-во сотен, десятков и единиц соответственно: ');
readln(a,b,c);
d:=a*100+b*10+c;
n:=sqr(a)+sqr(b)+sqr(c);
writeln('Сумма квадратов = ', n,#10, 'Само число: ',d);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика