tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу, которая
Написать программу, которая заполняет массив из 30 чисел и подсчитывает разность между минимальным и максимальным элементом
mog2
2 16.09.2019 13:50
1
Ответы
Нурлы11
07.10.2020 19:49
1. Современное решение
// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(30,-50,50); a.Println;
Writeln('Разность между минимальным и максимальным элементом ',
a.Max-a.Min)
end.
Пример
-31 41 -37 18 -44 -34 -13 7 30 -22 -33 47 -1 -4 -17 -21 32 -3 24 -15 43 -41 44 36 5 2 -47 -39 5 -13
Разность между минимальным и максимальным элементом 94
2. Так обычно (не не всегда!) учат в школе
program SelenaMarogom;
const
n=30;
var
i,min,max:integer;
a:array[1..n] of integer;
begin
Randomize;
min:=100; max:=-100;
for i:=1 to n do begin
a[i]:=Random(101)-50;
Write(a[i],' ');
if a[i]>max then max:=a[i];
if a[i]<min then min:=a[i]
end;
Writeln;
Writeln('Разность между минимальным и максимальным элементом ',max-min)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
abiersack
05.02.2022 15:08
Дополните таблицу таким образом, чтобы в ней можно было организовать вычисления общей площади наших лесов. Выполните соответствующие вычисления.И сделать круговую диограмму,...
olgayabs76oxczon
05.02.2022 15:11
Какое количество информации (с точки зрения алфавитного подхода) содержит восьмеричное число 1268?...
maksimtitov98
05.02.2022 15:16
Нужно написать арифметическое выражение на языке Паскаль...
Raul020507
05.02.2022 15:16
нарисовать робота в QBasic....
Anna256829
05.02.2022 15:16
. Модераторы Задание №2. Какое значение будет присвоено переменной х после завершения программы...
Тупойшкольник0
24.06.2019 00:30
Перевести число 2-чной системы счисления в 10-чную: 1110000/2, 10001101/2...
yulis1929
11.07.2019 10:50
Найдите ошибки в записи команд ,если они есть. a1: =b+2; a+b: =6; 6a: =d*2; sqr(c): =sqr(a)+sqr(b); a=8; x: =2y;...
Znanija027
09.09.2019 07:10
Нужна .. лазерный диск - 600 мб сколько страниц учебника можно записать на один диск, если 1 страница содержит 50 страниц, по 40 символов в строке?...
snkashleva133
09.09.2019 07:10
Что позволяет выбрать команда объекты базы ?...
NeonMax
09.09.2019 07:10
Интересная книга о компьютерах. авторы...
Популярные вопросы
Из данных слов составь пословицы, укажи род имён существительных,...
1
Переведите прямую речь в косвенную 1 he said,,i spend my holidays...
3
Обозначим за n%m операцию, возвращающую остаток от целочисленного...
3
Обозначим за n%m операцию, возвращающую остаток от целочисленного...
1
Найдите: художественную идею,тему и проблематику рассказа и.с.шмелева...
3
Из куска ткани можно сшить 12 детских плащей, расходуя на каждый...
1
Скільки буде 101,1×(0,37+1,,6-92,7)×0,031...
3
Определить растение злаковое...
3
Одна из сторон параллелограмма равна 5 см а высота опущенная на другую...
1
Мак, мята, рёв, рома, крёстный, крупа, крюк, сети, дым, дима, миска,...
1
// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(30,-50,50); a.Println;
Writeln('Разность между минимальным и максимальным элементом ',
a.Max-a.Min)
end.
Пример
-31 41 -37 18 -44 -34 -13 7 30 -22 -33 47 -1 -4 -17 -21 32 -3 24 -15 43 -41 44 36 5 2 -47 -39 5 -13
Разность между минимальным и максимальным элементом 94
2. Так обычно (не не всегда!) учат в школе
program SelenaMarogom;
const
n=30;
var
i,min,max:integer;
a:array[1..n] of integer;
begin
Randomize;
min:=100; max:=-100;
for i:=1 to n do begin
a[i]:=Random(101)-50;
Write(a[i],' ');
if a[i]>max then max:=a[i];
if a[i]<min then min:=a[i]
end;
Writeln;
Writeln('Разность между минимальным и максимальным элементом ',max-min)
end.