Написать программу, которая заменяет все заглавные буквы строчными, а строчные – заглавными в заданной символьной строке. (паскаль)

sorunbaevp00gzg sorunbaevp00gzg    3   28.06.2019 20:20    6

Ответы
leralera799 leralera799  02.10.2020 14:32
Program X; //работает только для русских строк
var   
    i: longint;   
    s: string;
begin
    readln(s);
    for i := 1 to length(s) do
        if (ord(s[i]) >= 192) and (ord(s[i]) <= 223) then
            s[i] := chr(ord(s[i]) + 32)
        else if (ord(s[i]) >= 224) and (ord(s[i]) <= 255) then
            s[i] := chr(ord(s[i]) - 32);
    writeln(s)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика