Написать программу которая задумывает число и печатает его наоборот. ( пример: 341 и 143) в паскаль.

princessTonya princessTonya    1   11.08.2019 18:10    3

Ответы
vitakotov009 vitakotov009  14.08.2020 12:29
A: = random(500)
Как перевернуть хз
ПОКАЗАТЬ ОТВЕТЫ
MSZaDrotE MSZaDrotE  14.08.2020 12:29
var m,p:longint;  
  i:integer;
begin
writeln ('Введите натуральное число не более 999999999');
repeat
readln(m);
until(m>0)and(m<=999999999);
 p:=0;
while m>0 do  
begin  
   i:=m mod 10;  
   p:=p*10+i;  
   m:=m div 10;
  end; write(p);
readln
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика