Написать программу, которая выводит синусы и косинусы. на языке си. заранее

masha091115 masha091115    3   31.03.2019 06:10    4

Ответы
barinovasonya0p00t3v barinovasonya0p00t3v  27.05.2020 21:01

1) Си-для начала  переменные нужно в начало функции объявлять. Если компилятор у тебя си как бы сказать си-шный,тои файл будет тоже си-шный
2)Самым первым аргументом для синуса и косинуса и формула пов(pow)будет вещественное число.
Так,косинус  и синус:
 cos(Xnumber,4) 
У функции синус и косинус только один параметр, а у pow совсем наоборот. 
 double Xnumber; и другие
I)все переменные нужно объявить , как double.  
Читать нужно будет так:
scanf("%lf", &Xnumber);
 тебе нужна для пов(pow)?
если да?,то вот:
Пов(pow)pow(cos(Xnumber), 4) + pow(sin(Ynumber), 2) + 1.0 / 4 * pow(sin(2*Xnumber), 2) - 1;
Вроде все,если понял(а),а если нет,то пиши в сообщение,и спрашивай,что не понятно
 

ПОКАЗАТЬ ОТВЕТЫ
chern8p08uo0 chern8p08uo0  27.05.2020 21:01

#include < iostream >    /* Подключаем библиотеку, чтоб работали функции cout, cin */
#include < cmath >    /*Подкючаем библиотеку, чтоб работали функции cos, pi */
#define PI 3.14159265   /*Задаем сколько у нас будет значит число ПИ */
using namespace std;

main (){  
         float a, result;   /*Вводим 2 переменные - действительные числа: одно - число градусов угла, второе - полученный результат*/
         cout << "Vvedite znachenie ugla" << endl;
         cin >> a;   /* Вводим значение угла с клавиатуры*/
         result = cos (a*PI/180);    /*высчитываем значение косинуса, переводя значениезаданного угла в радианы */
         cout << "Kosinus "<< a << " raven " << result;    /*Выводим полученное на экран */
         return 0;    /*Возвращает нулевое значение */
}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика