Написать программу, которая выводит на экран значения элементов массива в обратном порядке. в массиве 10 элементов, массив заполняется с случайных чисел из интервала (0, 100). (паскаль)

MilankaMarkova MilankaMarkova    3   20.05.2019 12:10    4

Ответы
seanius seanius  13.06.2020 22:13

 Program Massiv2;

Uses Crt;

var a:array[1..10] of integer;

       i:integer;

begin

     clrscr;

 

    randomize;

    for i:=1 to 10 do a[i]:=random(100)+1;

    write('Массив в обратном порядке: ');

     for i:=10 downto 1 do write(a[i],' ');  

     readkey;

 

 end.

ПОКАЗАТЬ ОТВЕТЫ
космос63 космос63  13.06.2020 22:13

Вот программа на C, выводит массив в прямом и обратном порядке:

 

#include <stdio.h>
#include <time.h>

void func(int *array, int n, int i)
{
  if (i < n) {
    array[i] = 0 + rand() % 100;
    printf("%d ", array[i]);
    func(array, n, i + 1);
    printf("%d ", array[i]);
  }
  else {
    printf("\n");
  }
}

int main(int argc, char *argv)
{
  srand(time(NULL));
  int array[10];
  func(array, 10, 0);
  return 0;
}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика