Написать программу которая выводит на экран все подмножества множества: {1,2,3,4}

ziatiok2016p074n4 ziatiok2016p074n4    1   29.05.2019 19:40    2

Ответы
timoshaisaev timoshaisaev  01.10.2020 14:27
var    
 a,b,c,d : integer;  
Begin  
   for a:=1 to 4 do    
    for b:=a+1 to 4 do        
     for c:=b+1 to 4 do    
      for d:=c+1 to 4 do        
       writeln(a:3,b:3,c:3,d:3);
     for a:=1 to 4 do
       for b:=a+1 to 4 do
        for c:=b+1 to 4 do
          writeln(a:3,b:3,c:3);
     for a:=1 to 4 do
       for b:=a+1 to 4 do
        writeln(a:3,b:3);
     for a:=1 to 4 do
       writeln(a:3);
    readln;
   End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика